Open Source Sofware

» Topic: contour ramping/helical interpolation

Home New Forums BobCAD-CAM Forums contour ramping/helical interpolation

This topic contains 4 replies, has 4 voices, and was last updated by  Bill 1 year, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18805

    Scott
    Participant

    Hello.

    I am having a problem in v24. I generate a drawing for a hole and then select ‘contour ramping’ in 2 axis milling to interpolate the hole. I am using a Fanuc 18 post processor that I downloaded from Bobcad. When I post the program, it gives me all of my circular moves to make the hole, but no ‘z’ move to move the tool down into the part. So, I wind up with a bunch of lines of code that are I’s and J’s only. When I run it on my machine it moves to the top of the part and proceeds to do the number of revolutions that are programmed without moving down any further.
    If I draw a rectangle and do the same thing, the code posts perfectly. I get an x, y and z move on each line.
    I get the same result (no z move) when I try to do thread milling.
    What I am (obviously) trying to accomplish is helical interpolation to produce holes with a cutter. Am I trying to use the wrong cycle? Do I have a parameter set wrong?
    Any help/suggestions would be greatly appreciated.

    Thanks
    Scott

    #18807

    Marco
    Participant

    Try to edit the post processor and set “debug_on” instead of “debug_off”. Then, for each line of the output file, you will see which line in the post processor is involved. I think looking at the differences in the code when it mills circle or rectangle you will understand where to correct the post processor.
    Hope this if of help
    Marco

    #18812

    Sean
    Participant

    Scott,

    This is because the movements for arcs are different than for linear and call from different blocks. In order to correct this, you will need to add a z-feed movement to the arc line. On block 64, after the y_f, add a , next to it and z_f after the ,.

    #19254

    Scott
    Participant

    Sorry for taking a while to get back on this.
    I tried adding the z as you suggested and it worked.
    I have only tried it on helical interpolation, not threading yet, but hopefully it will work the same.
    Thanks for your help.

    #20753

    Bill
    Participant

    I am having basically the same problem. Can some one explain in detail how to fix this? It goes to the bottom of the hole and moves in a circle but no Z up. THANKS TO ANY ONE WHO CAN HELP ME OUT!! Bill 320-237-3510

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Forum Account

     Lost Password / Register   

Sharing

facebooktwittergoogle_pluspinterestlinkedinmail

Recent Topics